Naming functions and methods
Function and method naming is not terribly difficult if the following two guidelines are observed:
Query functions return stuff. For example,
getare all functions which ask for something in return.
Command functions change state. For example,
Try very, very hard not to “mix and match”. Functions which both query and command are really hard to test, and worse, they are much harder to understand.
Think of it this way: testing a query function means testing only that the returned result is correct. Testing a command function means testing only the state of the object as a result of the command. If you have a function which commands and queries, you may find your function has weird interactions. Basically, your test code has to test the return, the state, and every possible interaction.
Plus, it’s just semantically confusing otherwise.
Update 2012/05/19: Command and query are analogous to “inspect” and “mutate” in the c++ world.